inloggen

Allereerst moeten we verbinding maken met een cisco device. Dit kan via en console kabel en een terminal programma (minicom op linux, snel en doeltreffend) of via telnet/ssh als het device al een ip adres heeft.
Elk cisco device heeft een drietal modes; de bekijk mode, de enable mode waarin meer zaken te bekijken zijn als de config de config mode waarin wijzigingen aangebracht kunnen worden in de configuratie.


telnet 10.0.0.1
Password: cisco
Switch>enable
Password: secret_wachtwoord
Switch#  (hekje in prompt geeft enable mode aan)
configure terminal
Switch(config)#  (config geeft config mode aan)
switch(config)# interface fastethernet 0/1
Switch(config-if)#  (geeft aan dat nu een interface geconfigureerd wordt
  

vraag info uit switch

Het eerste commando laat van alle interfaces zien of ze aangesloten zijn (en, belangrijk, of ze err-disabled zijn), op welke snelheid en in welk vlan. Het tweede commando laat wat meer info zien over een specifieke poort zoals paketten in en uit en ook de errors op de poort. Het derde commando laat van een interface specifieke info zien over trunking. Of de verbinding ook wel echt trunkt en welke vlan's eroverheen mogen. Dit is afhankelijk van de instellingen van beide switches waartussen de verbinding zit.


show interface status
show interface fastethernet 0/6
show interface fastethernet 0/6 switchport
  

Het eerste commando laat zien welke vlans er allemaal op deze switch voorkomen.
Het tweede commando laat zien of de switch een vtp client is of niet. Een vtp client krijgt zijn vlan info van een vtp server waarop nieuwe vlans worden aangemaakt. Cisco was eerst van mening dat dit de weg was maar later wilde men toch meer dat de vlans die ergens nodig waren lokaal worden aangemaakt omdat dit veiliger is. Het is wel belangrijk dat in een keten van switches alle switches alle vlans hebben die ergens in de keten worden gebruikt.
Het derde commando laat zien of de vtp informatie goed binnenkomt via de trunk verbindingen.


show vlan brief
show vtp statistics
show vtp counters
  

Om te zien waar een device zich bevindt in het netwerk kan het mac adres opgezocht worden in de mac tabel met het bovenste commando. Met het onderste commando kan gezien worden hoeveel en welke mac adressen op een bepaalde poort zitten en dus bijvoorbeeld ook of er nog een hub achter zit of een ip telefoon met pc doorgelust.
Het derde commando geeft aan welke buur switches een cisco apparaat heeft en op welke poorten. Dit is handig om je netwerk in kaart te brengen zonder fysiek de draadjes te volgen. Een combinatie van deze commando's is handig om een apparaat snel op te sporen in het netwerk. Je begint dan op de core switch met het zoeken naar een bepaald mac adres. Dan kun je zien welke switch aan de gevonden poort hangt en op die switch kun je hetzelfde weer herhalen tot je bij een eindpoort uitkomt waar het apparaat aanhangt.


show mac-address-table address 0102.0304.0506
show mac-address-table interface fastethernet 0/6
show cdp neigbours
  

poort instellingen

Commando's om een specifieke interface op een bepaalde snelheid of duplex mode te zetten. Bedenk dat fixed ingesteld aan een kant en auto aan de andere kant belabberde snelheden zal geven. beide kanten moeten of fixed ingesteld staan of auto sensing. Ik verkies zelf bij clients auto sensing en bij netwerk apparaten en servers fixed.
Onderaan staan de commando's om een poort in een ander vlan te zetten of een poort trunking te maken. Een trunk zal via vlan tagging alle vlans doorzetten (naar de volgende switch bijvoorbeeld). Wordt er dan echter een client aan gehangen dan is vlan 1 altijd het untagged vlan en alleen die zal dan gezien worden.
Bedenk dat bij oudere cisco switches meerdere protocollen nodig zijn voor trunking namelijk ISL en DOT1q. Gebruik waar mogelijk dot1q en stel dat op oudere 3500 switches ook in anders neemt deze default ISL. Zie laatste commando.


Switch(config)# interface fastethernet 0/6
Switch(config-if)# speed 10
Switch(config-if)# speed 100
Switch(config-if)# speed 1000
Switch(config-if)# speed auto
Switch(config-if)# duplex auto
Switch(config-if)# duplex half
Switch(config-if)# duplex full
Switch(config-if)# switchport access vlan 1
Switch(config-if)# switchport access vlan 8
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
  

snmp instellingen

Bij verhuizen van een switch zal de location aangepast moeten worden, een nieuwe waarde overschrijft een oude waarde. Wanneer een config in een nieuwe switch wordt gestopt (of een oude switch opnieuw geconfigureerd wordt) zal ook het chassis-id en het contact ingesteld moeten worden.


snmp-server location serverroom
snmp-server contact Automatisering, 06-64378337
snmp-server chassis-id Switch
  

remote toegang

De eerste groep is van de console via de kabel en een compoort. vty 0 tot 4 is van de telnet toegang waarvan er dus 4 tegelijk kunnen zijn. vty 5-15 is van de webinterface mits deze enabled is (laatste commando). login betekent dat er ingelogd mag worden op die manier en met password worden de paswoorden ingesteld.


 line con 0
  stopbits 1
 line vty 0 4
  password 7 01100F175804
  login
  international
 line vty 5 15
  password 7 0505031B254958
  login
 !
 ip http server
  

logging en tijd

Standaard worden logregels voorzien van het aantal uren/minuten sinds het aanzetten; heel handig is dit niet. Met onderstaande commando's wordt de tijd op de juiste tijdzone gezet, wordt de ntp server ingesteld, wordt de zomertijd ingesteld en wordt aangegeven dat de logging van log en debug met echte tijden gebeurt.
De onderste twee commando's geven aan wat de syslog server is en wat de logging facility is. De facility zorgt ervoor dat op de syslogserver deze data te scheiden is van andere loggings door deze in een aparte file te zetten.


service timestamps debug datetime localtime 
service timestamps log datetime localtime
clock timezone Amsterdam 1
clock summer-time Amsterdam recurring last Sun Mar 2:00 last Sun Oct 2:00
ntp server 10.0.0.250
logging facility local3
logging 10.0.0.250
  

losse commando's

Is een poort err-disabled (show interface status) dan doet hij het niet. Dit kan komen doordat een verbinding verkeerd geconfigureerd is of was en heeft staan klapperen. Het is op te lossen door de poort plat te leggen en weer vrij te geven shut wordt verder gebruikt om een verbinding te blokkeren bijvoorbeeld om mensen of hele gebouwen tijdelijk af te sluiten van het netwerk zonder dat je daarbij naar de fysieke poort hoeft te gaan om de stekker eruit te halen.


interface fastethernet 0/6
 shut
 no shut
!
  

Soms wil je zien of een poort errors heeft maar dan weet je niet hoe oud die errors zijn omdat de telling is vanaf dat de switch aan staat. Hiervoor is het handig de tellers te wissen en na enige tijd weer naar de poort te kijken.


clear counters
....
show interface fastethernet 0/6
  

Ditzelfde kan bij de logging, de mac adres table en de vtp tellers.


 clear logging
 clear mac-address-table
 clear vtp
  

save en backup

Alle wijzigingen worden in het geheugen gedaan en werken direct. Gaat er iets mis zet dan desnoods de switch uit en aan en de eerdere config zal weer starten. Werkt alles wel geef dan het eerste commando waarbij memory default is en weg gelaten mag worden.
Backuppen van een switch gaat met het copy commando waarna gevraagd wordt naar de tftp server en de filenaam.
Met sh flash zijn de bestanden op het filesystem te zien.


 write (memory)
 copy run tftp
   tftp.gouda.lok
   switch.txt
 show flash
  

Omgekeerd kan een defecte switch snel vervangen worden door de opgeslagen config in een andere switch weer terug te plakken.


 copy tftp run 
  tftp.gouda.lok
  switch.txt
  

Wel moet daarna nog even naar de vlan/vtp informatie gekeken worden want die staat in een aparte file.

etherchannels

Etherchannels worden gebruikt om verbindingen te bundelen om zo meer snelheid te krijgen. Dit moet dan ook op de aangesloten machine goed ingesteld worden. Controleer ook de werking want als een channel niet goed ingesteld is dan kan een server verkeer wisselend over meerdere netwerkkaarten sturen waardoor de switch het adres niet leert en alle verkeer geflood wordt over het hele netwerk.
Etherchannels worden bij andere merken ook wel trunks genoemd want dus verwarrend is. Bij cisco is een trunk een tunnel waar meer vlans doorheen kunnen en een etherchannel dus een bundeling van verbindingen.
Een etherchannel kan niet over twee switches gelegd worden behalve bij enkele modellen in een stack (gestackte 3750). Dit betekent dat er bij een dubbel aangesloten server gekozen moet worden tussen redundantie of een etherchannel als je geen gestackte dure switch hebt. Vaak haalt een server 1 Gbit niet in de praktijk dus test eerst of een channel wel een verbetering geeft voordat je de redundantie opgeeft.
De config varieert nogal bij verschillende cisco modellen en de devices waartussen het channel wordt opgebouwd. Check hiervoor de cisco site